autotools: point correct location of src
[debian/dhcpd-pools.git] / configure.ac
index 94bd968..5d2550a 100644 (file)
@@ -1,19 +1,36 @@
 #                                               -*- Autoconf -*-
 # Process this file with autoconf to produce a configure script.
 
-AC_PREREQ(2.63)
-AC_INIT([dhcpd-pools],[2.13],[kerolasa@iki.fi],,[http://dhcpd-pools.sourceforge.net/])
-AM_INIT_AUTOMAKE(dhcpd-pools, 2.13)
-AC_CONFIG_SRCDIR([config.h.in])
+AC_PREREQ(2.64)
+AC_CONFIG_MACRO_DIR([m4])
+AC_INIT([dhcpd-pools],[2.14],[kerolasa@iki.fi],,[http://dhcpd-pools.sourceforge.net/])
+AM_INIT_AUTOMAKE
+AC_CONFIG_SRCDIR([src/dhcpd-pools.h])
 AC_CONFIG_HEADERS([config.h])
 
-# Checks for programs.
+AC_GNU_SOURCE
+
+# Checks for programs
+AC_PROG_AWK
 AC_PROG_CC
+AC_PROG_CXX
+AC_PROG_MAKE_SET
+AC_PROG_LIBTOOL
 
 # Checks for libraries.
+LT_INIT
 
 # Checks for header files.
-AC_CHECK_HEADERS([arpa/inet.h fcntl.h libintl.h netinet/in.h stdlib.h string.h strings.h sys/socket.h unistd.h])
+
+AC_CHECK_HEADERS([arpa/inet.h \
+       fcntl.h \
+       libintl.h \
+       netinet/in.h \
+       stdlib.h \
+       string.h \
+       strings.h \
+       sys/socket.h \
+       unistd.h])
 
 # Checks for typedefs, structures, and compiler characteristics.
 AC_HEADER_STDBOOL
@@ -21,7 +38,7 @@ AC_TYPE_SIZE_T
 
 # Checks for library functions.
 AC_FUNC_MALLOC
-AC_CHECK_FUNCS([inet_ntoa memset strerror strstr])
+AC_CHECK_FUNCS([inet_ntoa memset strerror strstr strdup])
 
 # GNU commandline parsing in getopt.h present?
 AC_CHECK_HEADERS(getopt.h, AC_DEFINE(HAVE_GETOPT_H),